Thursday, January 19, 2006

BugMeNot


The BugMeNot Firefox extension is now compatible with Firefox 1.5.


[via roachfiend.com]


Technorati Tags: ,